
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.pasadenaweekly.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="union station turkeys, union station, union station thanksgiving" />
<meta name="news_keywords" content="union station turkeys, union station, union station thanksgiving" />
<meta name="description" content="Many of Pasadena&rsquo;s most vulnerable and unsheltered people may find out what Thanksgiving is like without a turkey." />
<meta name="author" content="Pasadena Weekly Staff" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?crop=1280%2C672%2C0%2C90&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Union Station has urgent need for frozen turkeys" />
<meta property="og:description" content="Many of Pasadena&rsquo;s most vulnerable and unsheltered people may find out what Thanksgiving is like without a turkey." />
<meta property="og:site_name" content="Pasadena Weekly" />
<meta property="og:section" content="News" />
<meta property="article:publisher" content="https://www.facebook.com/PasadenaWeekly" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?crop=1280%2C672%2C0%2C90&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@pasadenaweekly" />
<meta name="twitter:image:alt" content="Union" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.1c52af6b9bc35f467ffe99508ecf766a.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.6ee2c17f3ef34e32b5fa02524f5978e7.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.65.1"},"crm":{"group_id":"308"},"content":{"id":"807cd14c-663f-11ed-ac2e-a3751ae591ec","title":"Union Station has urgent need for frozen turkeys","type":"article","published_time":"2022-11-17T08:00:00Z","tags":["union station turkeys","union station","union station thanksgiving"],"authors":[],"taxnonomies":{"blox_sections":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/section","items":["news"]},"blox_flags":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/flag","items":[]}},"metrics":{"image_count":1,"video_count":0,"audio_count":0,"word_count":228},"byline":"By Pasadena Weekly Staff"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Pasadena Weekly Staff","start_hour":"00","id":"807cd14c-663f-11ed-ac2e-a3751ae591ec","app":"editorial","ga_page":"\/news\/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":239},"client":{"is_bot":"yes","is_gdpr":"no"},"google":{"ua":"UA-21325522-7"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.7b5fd2a1aa906214ae39b25cd6ec9283.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.ef1ae2cf9d9803199a19b009dc464018.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://prebid.voqally.com/voqally_prebid.min.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];
    
    googletag.cmd.push(function(){
        googletag.pubads().disableInitialLoad();
    });

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '807cd14c-663f-11ed-ac2e-a3751ae591ec';
    __tnt.ads.dfp.targeting.k = ["union station turkeys","union station","union station thanksgiving"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.a023713b7eff47127899286dc36e1970.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.fc1a4213adeec354910108f84bf0e732.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.d45f12d51e6b121b88d52db2e387136f.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/pasadenaweekly.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_SKIN_LR';
            
                gptAdSlots['ad-2580511'] = googletag.defineOutOfPageSlot(adUnit, 'ad-2580511').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_728x90_TOP_ROS_LEADERBOARD';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2580505'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2580505').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_728x90_BOTTOM_ROS_LEADERBOARD';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2580508'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2580508').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x250_TOP_ARTICLE';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[728,90],[300,250]]).addSize([992, 0], [[728,90],[300,250]]).addSize([1200, 0], [[728,90],[300,250]]).build();
                gptAdSlots['ad-2580532'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-2580532').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x250_BOT_ARTICLE';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[728,90],[300,250]]).addSize([992, 0], [[728,90],[300,250]]).addSize([1200, 0], [[728,90],[300,250]]).build();
                gptAdSlots['ad-2580538'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-2580538').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x250_TOP_SIDEBAR';
            
                gptAdSlots['ad-2580517'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2580517').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x600_MID_SIDEBAR';
            
                gptAdSlots['ad-2580523'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2580523').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x250_MID_SIDEBAR';
            
                gptAdSlots['ad-2580520'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2580520').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_300x250_BOT_SIDEBAR';
            
                gptAdSlots['ad-2580526'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-2580526').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/6099645/pasadenaweekly.com/PW_728x90_BOTTOM_ROS_FOOTER';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [[970,90],[728,90]]).addSize([992, 0], [[970,90],[728,90]]).addSize([1200, 0], [[970,90],[728,90]]).build();
                gptAdSlots['ad-2580529'] = googletag.defineSlot(adUnit, [[320,50],[970,90],[728,90]], 'ad-2580529').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Union Station has urgent need for frozen turkeys | News | pasadenaweekly.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #2E2C2C; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #67999A; } .fixed-nav #main-navigation { background-color: #67999A !important; } #site-top-nav-container, #site-top-nav { background-color: #67999A; } #site-footer-container, #site-footer { background-color: #D5DADE; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #D6D6D6; } .navbar-toggle .icon-bar { background-color: #D6D6D6 !important; } .navbar-toggle .sr-only-show { color: #D6D6D6 !important; } #site-top-nav .list-inline>li>a { color: #FFFF; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #67999A; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #D6D6D6; } }#site-copyright a, #site-footer a { color: #000; }.body-texture{ background-image:url('https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/images/textures/fancy_deboss_e1.96e6c4827b2092c13d3732e249164afa.png'); }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #D6D6D6; }#site-header-container{ border-bottom: 3px solid #D6D6D6; }#site-footer-container{ border-top: 3px solid #D6D6D6; } .tnt-bg-accent { background-color: #D6D6D6; } a .tnt-caret-down { color: #D6D6D6; } .block-title .block-title-inner { border-color: #D6D6D6; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #D6D6D6; } .form-control:focus { border-bottom-color: #D6D6D6; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ .label-ad:before { content: "ADVERTISEMENT"; font: normal 10px/10px sans-serif; color: #888; padding-left: calc(50% - 44px); } /* Variables */ /*These variables control the colors of the buttons. If changing the colors of buttons, change the color here rather than in the actual css. */ .btn {transition:all .3s;} .btn-primary {background-color:#1E4652; border-color:#1E4652;} .btn-primary:hover, .btn-primary:focus {background-color:#193A44; border-color:#193A44;} .btn-warning {background-color:#f0ad4e; border-color:#f0ad4e;} .btn-warning:hover, .btn-warning:focus {background-color:#ec971f; border-color:#ec971f;} .btn-success {background-color:#5cb85c; border-color:#5cb85c;} .btn-success:hover, .btn-success:focus {background-color:#449d44; border-color:#449d44;} .btn-danger {background-color:#d9534f; border-color:#d9534f;} .btn-success:hover, .btn-success:focus {background-color:#c9302c; border-color:#c9302c;} .search-form-container, .panel {background-color:#F1EDED;} /* Header */ #topbar-col-one {width:50%;} #topbar-col-two {width:16.666%;} #tncms-block-672560 img {max-width:728px; margin:0 auto 10px;} .follow-links-672610 li a, .follow-links-672610 li a:focus, .follow-links-672610 li a:active {height:22px!important; width:22px!important; font-size:14px!important;} .site-search {margin-top:0px;} .search-form-container input.form-control{margin-bottom:0 !important;margin-top:5px;margin-left:2px;border-radius:0;background:none !important;height:42px} #tncms-region-main-nav-right-region {margin-left:20px;} #tncms-region-main-nav-right-region, #tncms-region-nav-main-nav-right-nav {float:right;} #topbar-col-three-nav_menu {text-align:right; float:right; margin-left:10px!important;} /* Body */ .block-title .block-title-inner, .user-header .user-header-inner {padding:0 15px 8px 0; margin-bottom:-1px; border-bottom:4px solid transparent; width:100%;} .block-title .block-title-inner {border-color:#67999A;} .link-to-button .block-links {border:none!important; text-align:right;} .link-to-button .block-links a {padding:10px 16px; font-size:18px; line-height:1.33; color:#fff; background-color:#1E4652; border-color:#1E4652; text-decoration:none!important;} .link-to-button .block-links a:hover, .link-to-button .block-links a:focus {background-color:#193A44; border-color:#193A44;} #tncms-block-1479576 li {counter-increment:itemCount; margin-bottom:15px;} #tncms-block-1479576 li:nth-child(1), #tncms-block-1479576 li:nth-child(2), #tncms-block-1479576 li:nth-child(3) {font-weight:bold;} #tncms-block-1479576 li:before {content:counter(itemCount); display:block; width:23px; height:23px; line-height:23px; text-align:center; color:#fff; background:#2e2c2c; float:left; margin-right:15px; font-size:16px; font-weight:bold;} #tncms-block-1479576 li a {font-size:16px;} .block-side-board .ad-placeholder {min-height:600px;} .no-panel .panel {border:none; box-shadow:none;} .card-grid .card-meta {display:inline-block;} .card-grid .card-social {margin-top:-5px;} .mosaic-grid .mosaic-item {border:2px solid #fff;} .ad-bg .tnt-ads-container {background-color:#eee; padding:5px 0;} /* Footer */ #site-footer-container {border-top:3px solid #67999A;} /* Media Queries */ @media screen and (min-width: 768px) { .ad-bg .tnt-ads, .ad-bg .tncms-region-ads div:first-child, .ad-bg .tnt-ads-container div:first-child {margin-bottom:0px!important;} } @media (max-width:991px) { .navbar-brand img {max-height:40px; margin-top:-13px;} .offcanvas-drawer, .offcanvas-drawer .user-controls, .offcanvas-drawer .search-form-container {background:#DBE0E3; box-shadow:none!important; text-shadow:none;} .offcanvas-drawer * {color:#333!important;} .offcanvas-drawer .navbar-nav li, .offcanvas-drawer .navbar-nav .panel-title {border-bottom:1px solid rgba(0,0,0,0.03)!important;} } @media (min-width:992px) and (max-width:1199px) { .nav>li>a {padding:15px 8px;} } .social-links .pull-right li a, .social-links .pull-right li a:focus, .follow-links-2288518 li a:active { height: 22px; width: 22px; font-size: 14px; } #tncms-region-masthead-full-top img { display: none; } #site-top-nav .list-inline.nav-list>li {margin-right: 7px;} #site-header {padding: 0;} #tncms-region-main-nav-brand {margin-top: 5px;} .offcanvas-drawer, .offcanvas-drawer .user-controls, .offcanvas-drawer .search-form-container {background: #67999A;box-shadow: none!important;text-shadow: none;} .offcanvas-drawer .navbar-nav .panel-title .expand-children, .offcanvas-drawer .navbar-nav .panel-title a, .offcanvas-drawer .navbar-nav li a, .offcanvas-drawer .open .dropdown-menu>li>a {text-shadow: none !important;} #mobile-nav-right_menu .collapse .nav-link {color: #FFF !important;} .offcanvas-drawer * {color: #fff!important;} </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.pasadenaweekly.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Union Station has urgent need for frozen turkeys | News | pasadenaweekly.com" href="http://www.pasadenaweekly.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a7c71fa5a63ad1158170fb2c085be042.js"></script>
            <!-- Custom Code Here -->
<!-- VoiceMedia Prebid 04/27/22 Start -->

<script async="async" src="https://prebid.voqally.com/voqally_prebid.min.js"></script>

<!-- VoiceMedia Prebid 04/27/22  End -->

<!-- Mailchimp Popup --> 
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/0d04049df38fb8464a29c6623/8a21a60312712e74e1c2fd8c7.js");</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-4J9STL671W"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-4J9STL671W');
</script>
        </head>
        <body class="fixed-scroll-nav app-editorial grid-pattern blox-asset uuid-807cd14c-663f-11ed-ac2e-a3751ae591ec  section-news type-article infinity-disabled body-texture" data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.pasadenaweekly.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.65.1&amp;townnews.crm.group_id=308&amp;townnews.content.id=807cd14c-663f-11ed-ac2e-a3751ae591ec&amp;townnews.content.title=Union+Station+has+urgent+need+for+frozen+turkeys&amp;townnews.content.type=article&amp;townnews.content.published_time=2022-11-17T08%3A00%3A00Z&amp;townnews.content.tags.0=union+station+turkeys&amp;townnews.content.tags.1=union+station&amp;townnews.content.tags.2=union+station+thanksgiving&amp;townnews.content.taxnonomies.blox_sections.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fsection&amp;townnews.content.taxnonomies.blox_sections.items.0=news&amp;townnews.content.taxnonomies.blox_flags.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fflag&amp;townnews.content.metrics.image_count=1&amp;townnews.content.metrics.video_count=0&amp;townnews.content.metrics.audio_count=0&amp;townnews.content.metrics.word_count=228&amp;townnews.content.byline=By+Pasadena+Weekly+Staff&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Pasadena+Weekly+Staff&amp;tncms.asset.start_hour=00&amp;tncms.asset.id=807cd14c-663f-11ed-ac2e-a3751ae591ec&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=239&amp;tncms.client.is_bot=yes&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-21325522-7&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.pasadenaweekly.com/tncms/admin/editorial-asset/?edit=807cd14c-663f-11ed-ac2e-a3751ae591ec"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-2288527" class="tncms-block hidden-md hidden-lg"><div id="user-controls-2288527" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.pasadenaweekly.com/users/signup/?referer_url=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.pasadenaweekly.com/users/login/?referer_url=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.pasadenaweekly.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-2288527').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.pasadenaweekly.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.pasadenaweekly.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.pasadenaweekly.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-2288527').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.pasadenaweekly.com/users/logout/" id="user-logout-form-2288527"><input type="hidden" name="referer_url" value="https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/feature_stories/"  class="nav-link tnt-section-features ">Features</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/dining/"  class="nav-link tnt-section-dining ">Dining</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/arts_and_events/"  class="nav-link tnt-section-arts-culture ">Arts & Culture</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/recommended/"  class="nav-link tnt-section-recommended ">Recommended</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-more expand-label">More</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/special_issues/"  class="nav-link tnt-section-special-issues">Special Issues</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.pasadenaweekly.com/site/legals.html"  target="_blank" rel="noopener" class="nav-link tnt-section-legals">Legals</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-2288515" class="tncms-block hidden-md hidden-lg"><section id="block-2288515" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-2288515" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-2288515" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-2288515" class="site-search-form input-group default normal form-control">
        <label for="site-search-2288515-term" class="sr-only">Site search</label>
        <input id="site-search-2288515-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2288515-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-2288515" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-2288851" class="tncms-block"><style>

@media all and (min-device-width: 700px) and (max-device-width: 728px) {#leaderboard-pixfuture {transform: scale(0.9);}} @media all and (min-device-width: 671px) and (max-device-width: 699px) {#leaderboard-pixfuture {transform: scale(0.9);transform-origin: 0 0;}} @media all and (min-device-width: 651px) and (max-device-width: 670px) {#leaderboard-pixfuture {transform: scale(0.88);transform-origin: 0 0;}} @media all and (min-device-width: 631px) and (max-device-width: 650px) {#leaderboard-pixfuture {transform: scale(0.85);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 560px) and (max-device-width: 600px) {#leaderboard-pixfuture {transform: scale(0.75);transform-origin: 0 0;}} @media all and (min-device-width: 520px) and (max-device-width: 559px) {#leaderboard-pixfuture {transform: scale(0.7);transform-origin: 0 0;}} @media all and (min-device-width: 491px) and (max-device-width: 519px) {#leaderboard-pixfuture {transform: scale(0.65);transform-origin: 0 0;}} @media all and (min-device-width: 451px) and (max-device-width: 490px) {#leaderboard-pixfuture {transform: scale(0.6);transform-origin: 0 0;}} @media all and (min-device-width: 401px) and (max-device-width: 450px) {#leaderboard-pixfuture {transform: scale(0.55);transform-origin: 0 0;}} @media all and (min-device-width: 371px) and (max-device-width: 400px) {#leaderboard-pixfuture {transform: scale(0.5);transform-origin: 0 0;}} @media all and (min-device-width: 341px) and (max-device-width: 370px) {#leaderboard-pixfuture {transform: scale(0.46);transform-origin: 0 0;}} @media all and (min-device-width: 301px) and (max-device-width: 340px) {#leaderboard-pixfuture {transform: scale(0.42);transform-origin: 0 0;}} @media all and (max-device-width: 300px) {#leaderboard-pixfuture {transform: scale(0.4);transform-origin: 0 0;}}

</style></div><div id="tncms-block-2580511" class="tncms-block hidden"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580511" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580511');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link    tnt-section-about"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="/site/contact.html"  tabindex="0" >
                    <span class="nav-label ">| Contact</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="https://www.pasadenaweekly.com/site/forms/advertise/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">| Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-employment"  href="https://timespublications.com/#careers"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">| Employment</span>
                </a></li><li>
                <a class="nav-link    tnt-section-digital-edition"  href="/site/digital_edition/"  tabindex="0" >
                    <span class="nav-label ">| Digital Edition</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-two" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list"></ul></div></div>
    <div id="topbar-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-three" class="tncms-region "><div id="tncms-block-2288518" class="tncms-block social-links pull-right padding-top"><div class="follow-links-2288518 follow-links pull-right">
    
    <section id="block-2288518" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/PasadenaWeekly" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/pasadenaweekly" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.pasadenaweekly.com",
  "sameAs" : ["https://www.facebook.com/PasadenaWeekly","https://twitter.com/pasadenaweekly"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-2718516" class="tncms-block link-to-button top-nav pull-right padding-right padding-top"><section id="block-2718516" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="clearfix">
        <ul class="list-inline block-links pos-top ">
            
                
                    <li><a href="https://www.pasadenaweekly.com/e-subscribe/" class="">Subscribe</a></li>
                
            
            
        </ul></div></section></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-2580505" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580505" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580505');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2288419" class="tncms-block padding-bottom"><section id="block-2288419" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  aria-label="Pasadena Weekly">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=150%2C51 150w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=200%2C68 200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=225%2C76 225w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=300%2C102 300w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=400%2C136 400w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="512"
                height="174"
                alt="Pasadena Weekly"
                ></a></div></section></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-2288419" class="tncms-block padding-bottom"><section id="block-2288419" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  aria-label="Pasadena Weekly">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=150%2C51 150w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=200%2C68 200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=225%2C76 225w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=300%2C102 300w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png?resize=400%2C136 400w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/589484a4-8e77-11ec-9099-7f458bd9d4ca.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="512"
                height="174"
                alt="Pasadena Weekly"
                ></a></div></section></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-2288503" class="tncms-block"><section id="block-2288503" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  aria-label="Scottsdale Progress">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png?resize=150%2C50 150w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png?resize=200%2C66 200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png?resize=225%2C74 225w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png?resize=300%2C99 300w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png?resize=400%2C132 400w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/custom/image/352afac8-85dc-11ec-9099-331db75ad9b1.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="512"
                height="169"
                alt="Scottsdale Progress"
                ></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-2288512" class="tncms-block site-search"><ul id="site-search-2288512-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-2288512" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-2288512" class="site-search-form input-group pull-right input-group-lg ">
        <label for="site-search-2288512-term" class="sr-only">Site search</label>
        <input id="site-search-2288512-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-2288512-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-2288512" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div><div id="tncms-block-2288530" class="tncms-block"><div id="weather-2288530" class="weather-current size-nav pull-right">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=91031" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">55&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="91031">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_2288530" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    South Pasadena, CA
                                
                                <small>(91031)</small>
                            </h4><h5>Today</h5>
                                <p>A clear sky. Low 48F. Winds light and variable..
                                </p>
                                <h5>Tonight</h5>
                                <p>A clear sky. Low 48F. Winds light and variable.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: November 17, 2022 @ 11:04 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=91031"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a href="/" class="nav-link tnt-section-home" >Home
                </a></li><li>
                <a href="/news" class="nav-link tnt-section-news" >News
                </a></li><li>
                <a href="/feature_stories/" class="nav-link tnt-section-features" >Features
                </a></li><li>
                <a href="/opinion" class="nav-link tnt-section-opinion" >Opinion
                </a></li><li>
                <a href="/dining/" class="nav-link tnt-section-dining" >Dining
                </a></li><li>
                <a href="/arts_and_events/" class="nav-link tnt-section-arts-culture" >Arts & Culture
                </a></li><li>
                <a href="/sports/" class="nav-link tnt-section-sports" >Sports
                </a></li><li>
                <a href="/recommended/" class="nav-link tnt-section-recommended" >Recommended
                </a></li><li class="dropdown yamm-fw more">
                <a class="dropdown-toggle nav-link tnt-section-more" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  >More
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-more-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-special-issues" href="/special_issues/" >Special Issues</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-legals" href="https://www.pasadenaweekly.com/site/legals.html"  target="_blank" rel="noopener">Legals</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-more-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-more-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-more-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li></ul>
    </div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-2580508" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580508" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580508');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-a98cbe80-663f-11ed-9b39-cb8d144045c7" class="modal fullscreen in modal-image image-default modal-a98cbe80-663f-11ed-9b39-cb8d144045c7" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-white">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=400%2C267"
                        srcset="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=150%2C100 150w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=225%2C150 225w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=640%2C427 640w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=990%2C660 990w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1035%2C690 1035w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1280%2C853 1333w"
                        sizes="100vw"
                        
                        width="1280"
                        height="853"
                        alt="Union"
                        class="img-responsive true-size white" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-a98cbe80-663f-11ed-9b39-cb8d144045c7" data-target=".caption-inner-modal-image-a98cbe80-663f-11ed-9b39-cb8d144045c7">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-a98cbe80-663f-11ed-9b39-cb8d144045c7 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pasadenaweekly.com%2Funion%2Fimage_a98cbe80-663f-11ed-9b39-cb8d144045c7.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Union&via=pasadenaweekly&url=https%3A%2F%2Fwww.pasadenaweekly.com%2Funion%2Fimage_a98cbe80-663f-11ed-9b39-cb8d144045c7.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.pasadenaweekly.com/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.pasadenaweekly.com/tncms/asset/editorial/a98cbe80-663f-11ed-9b39-cb8d144045c7" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPasadena%20Weekly%5D%20Union&body=https%3A%2F%2Fwww.pasadenaweekly.com%2Funion%2Fimage_a98cbe80-663f-11ed-9b39-cb8d144045c7.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a98cbe80-663f-11ed-9b39-cb8d144045c7"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.pasadenaweekly.com/union/image_a98cbe80-663f-11ed-9b39-cb8d144045c7.html', '[data-copy-inline-a98cbe80-663f-11ed-9b39-cb8d144045c7]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Image link copied to clipboard"
                    data-copy-inline-a98cbe80-663f-11ed-9b39-cb8d144045c7
                >
                    <span class="tnt-stack" title="Copy image link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-a98cbe80-663f-11ed-9b39-cb8d144045c7-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="a98cbe80-663f-11ed-9b39-cb8d144045c7" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="a98cbe80-663f-11ed-9b39-cb8d144045c7" class="save-list-a98cbe80-663f-11ed-9b39-cb8d144045c7-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="a98cbe80-663f-11ed-9b39-cb8d144045c7" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-a98cbe80-663f-11ed-9b39-cb8d144045c7 img { max-height: 853px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-807cd14c-663f-11ed-ac2e-a3751ae591ec" class="asset article-default"  data-url="https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Many of Pasadena’s most vulnerable and unsheltered people may find out what Thanksgiving is like without a turkey. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?crop=1280%2C672%2C0%2C90&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="pasadenaweekly.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" />
    <style>
                .asset-paging .direction {
                    color: #D6D6D6;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.pasadenaweekly.com\/tncms\/search\/mlt\/?origin=807cd14c-663f-11ed-ac2e-a3751ae591ec&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-807cd14c-663f-11ed-ac2e-a3751ae591ec" class="asset-paging">
                <div id="paging-prev-807cd14c-663f-11ed-ac2e-a3751ae591ec" class="paging-link prev offset"></div>
                <div id="paging-next-807cd14c-663f-11ed-ac2e-a3751ae591ec" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
    <span>Union Station has urgent need for frozen turkeys</span>
</h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By Pasadena Weekly Staff</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-11-17T00:00:00-08:00" class="tnt-date asset-date text-muted">
            Nov 17, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-11-17T00:00:00-08:00" class="tnt-date asset-date text-muted">23 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-11-17T00:00:00-08:00">
    <meta itemprop="datePublished" content="2022-11-17T00:00:00-08:00">
    <meta itemprop="dateModified" content="2022-11-17T00:00:00-08:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&via=pasadenaweekly&url=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.pasadenaweekly.com/tncms/asset/editorial/807cd14c-663f-11ed-ac2e-a3751ae591ec" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPasadena%20Weekly%5D%20Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&body=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-white"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-a98cbe80-663f-11ed-9b39-cb8d144045c7" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-a98cbe80-663f-11ed-9b39-cb8d144045c7" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1280">
            <meta itemprop="height" content="853">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1200%2C800">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1200%2C800"><img
                        src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=400%2C267"
                        srcset="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=150%2C100 150w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=225%2C150 225w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=640%2C427 640w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=990%2C660 990w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1035%2C690 1035w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/content/tncms/assets/v3/editorial/a/98/a98cbe80-663f-11ed-9b39-cb8d144045c7/6375d24a5eab7.image.jpg?resize=1280%2C853 1333w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="1280"
                        height="853"
                        alt="Union"
                        class="img-responsive full tnt-restrict-img-a98cbe80-663f-11ed-9b39-cb8d144045c7 white" />
            </div><style>
                .tnt-restrict-img-a98cbe80-663f-11ed-9b39-cb8d144045c7 {
                    max-width: 1280px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="807cd14c-663f-11ed-ac2e-a3751ae591ec">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&via=pasadenaweekly&url=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.pasadenaweekly.com/tncms/asset/editorial/807cd14c-663f-11ed-ac2e-a3751ae591ec" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPasadena%20Weekly%5D%20Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&body=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html', '[data-copy-inline-top-807cd14c-663f-11ed-ac2e-a3751ae591ec]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-top-807cd14c-663f-11ed-ac2e-a3751ae591ec
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-807cd14c-663f-11ed-ac2e-a3751ae591ec-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="807cd14c-663f-11ed-ac2e-a3751ae591ec" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="807cd14c-663f-11ed-ac2e-a3751ae591ec" class="save-list-807cd14c-663f-11ed-ac2e-a3751ae591ec-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="807cd14c-663f-11ed-ac2e-a3751ae591ec" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>Many of Pasadena’s most vulnerable and unsheltered people may find out what Thanksgiving is like without a turkey.</p><p>Due to the nationwide shortage and rising price of turkeys, Union Station Homeless Services has a desperate need for frozen turkeys. As part of the annual Dinner in the Park tradition, meals are offered to adults and families experiencing homelessness and poverty; senior citizens; and those who are alone at the holidays or unable to afford a holiday meal.</p><p>“I have never seen the need so dire,” said David Sensente Sr., manager of in-kind donations and a 20-year employee of Union Station Homeless Services.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-2580532" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580532" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580532');
                        
                });
            </script>
        </div>
    </div>
</div></div><p>“Many longtime donors are not committing to supplying turkeys this year. We need the community to be generous and help us offer a holiday meal to those who need it the most.”</p><p>The needed 450 turkeys will be part of over 4,000 meals during the week of Thanksgiving either as part of handing out “All the Fixings” meal supply boxes, prepared Thanksgiving meals for reheating, and private sit-down dinners on Thanksgiving Day at Union Station Homeless Services facilities.</p><p>Frozen turkeys can be dropped off at the Union Station Homeless Services Adult Center (412 S. Raymond Avenue, Pasadena) any day from 8 a.m. to 2:30 p.m. The complete list of needs for Dinner in the Park is at <a href="http://unionstationhs.org/dinner-in-the-park">unionstationhs.org/dinner-in-the-park</a>.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-2580538" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580538" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580538');
                        
                });
            </script>
        </div>
    </div>
</div></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&via=pasadenaweekly&url=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.pasadenaweekly.com/tncms/asset/editorial/807cd14c-663f-11ed-ac2e-a3751ae591ec" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPasadena%20Weekly%5D%20Union%20Station%20has%20urgent%20need%20for%20frozen%20turkeys&body=https%3A%2F%2Fwww.pasadenaweekly.com%2Fnews%2Funion-station-has-urgent-need-for-frozen-turkeys%2Farticle_807cd14c-663f-11ed-ac2e-a3751ae591ec.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"807cd14c-663f-11ed-ac2e-a3751ae591ec"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.pasadenaweekly.com/news/union-station-has-urgent-need-for-frozen-turkeys/article_807cd14c-663f-11ed-ac2e-a3751ae591ec.html', '[data-copy-inline-807cd14c-663f-11ed-ac2e-a3751ae591ec]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-807cd14c-663f-11ed-ac2e-a3751ae591ec
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-807cd14c-663f-11ed-ac2e-a3751ae591ec-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="807cd14c-663f-11ed-ac2e-a3751ae591ec" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="807cd14c-663f-11ed-ac2e-a3751ae591ec" class="save-list-807cd14c-663f-11ed-ac2e-a3751ae591ec-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="807cd14c-663f-11ed-ac2e-a3751ae591ec" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22union%20station%20turkeys%22#tncms-source=keyword" class="tag-union-station-turkeys label label-default"  rel="nofollow">Union Station Turkeys</a>
                </li> <li>
                    <a href="/search/?k=%22union%20station%22#tncms-source=keyword" class="tag-union-station label label-default"  rel="nofollow">Union Station</a>
                </li> <li>
                    <a href="/search/?k=%22union%20station%20thanksgiving%22#tncms-source=keyword" class="tag-union-station-thanksgiving label label-default"  rel="nofollow">Union Station Thanksgiving</a>
                </li> </ul>
                        </div>
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-2718561" class="tncms-block pull-right"><section id="block-2718561" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-2718561 ">
        <div class="block-title-inner">
            <h3>
                
                Digital Edition
                
            </h3>
        </div>
    </div></div><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><p>Never miss an issue. Sign up for free.</p><a href="https://www.pasadenaweekly.com/e-subscribe/">
                <button type="button" class="btn btn-primary  ">Subscribe</button>
            </a></div>
</article></div>
    </div></section></div><div id="tncms-block-2288725" class="tncms-block"><h4 class="blox-title"><strong>Pasadena Weekly</strong></h4>
<iframe id="bloxFrame" src="https://static.issuu.com/widgets/shelf/index.html?folderId=02bcd04f-47e9-4cdf-9b7a-7a4286718f54&amp;theme=theme3&amp;rows=1&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=true&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true" name="bloxFrame" width="100%" height="200px" frameborder="0" scrolling="auto">
</iframe></div><div id="tncms-block-2580517" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580517" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580517');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2532379" class="tncms-block"><script defer src="https://www.voqally.com/hub/app/r.js?key=989ab980ba943f9d41b7767dea8cf495"></script></div><div id="tncms-block-2580523" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580523" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580523');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2288692" class="tncms-block"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FPasadenaWeekly%2F&amp;tabs=timeline&amp;width=360&amp;height=650&amp;small_header=false&amp;adapt_container_width=true&amp;hide_cover=false&amp;show_facepile=true&amp;appId" width="360" height="650" style="border:none;overflow:hidden; display:block; margin:0 auto 40px;" scrolling="no" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe>
<br></div><div id="tncms-block-2580520" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580520" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580520');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-2651556" class="tncms-block"><a class="twitter-timeline" data-height="300" href="https://twitter.com/pasadenaweekly?ref_src=twsrc%5Etfw">Tweets by pasadenaweekly</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br></div><div id="tncms-block-2580526" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580526" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580526');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-2580529" class="tncms-block label-ad"><div class="tnt-ads-container text-center  " >
        <div id="ad-2580529" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-2580529');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-2288737" class="tncms-block"><script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/0d04049df38fb8464a29c6623/8a21a60312712e74e1c2fd8c7.js");</script></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-2288491" class="tncms-block"><section id="block-2288491" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2288491 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link   nav-home  tnt-section-home"  href="/"  tabindex="0" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label sr-only">Home</span>
                </a></li><li>
                <a class="nav-link    tnt-section-news"  href="/news"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-features"  href="/feature_stories/"  tabindex="0" >
                    <span class="nav-label ">Features</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-arts-culture"  href="/arts_and_events/"  tabindex="0" >
                    <span class="nav-label ">Arts & Culture</span>
                </a></li><li>
                <a class="nav-link    tnt-section-dining"  href="/dining/"  tabindex="0" >
                    <span class="nav-label ">Dining</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-recommended"  href="/recommended/"  tabindex="0" >
                    <span class="nav-label ">Recommended</span>
                </a></li><li>
                <a class="nav-link    tnt-section-special-issues"  href="/special_issues/"  tabindex="0" >
                    <span class="nav-label ">Special Issues</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-2288395" class="tncms-block"><section id="block-2288395" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2288395 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-about"  href="https://www.pasadenaweekly.com/site/about.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">About</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="https://www.pasadenaweekly.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Contact</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="https://www.pasadenaweekly.com/site/forms/advertise/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-employment"  href="https://timespublications.com/#careers"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Employment</span>
                </a></li><li>
                <a class="nav-link    tnt-section-legals"  href="https://www.pasadenaweekly.com/site/legals.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Legals</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Local Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-e-subscribe"  href="/e-subscribe/"  tabindex="0" >
                    <span class="nav-label ">E-Subscribe</span>
                </a></li><li>
                <a class="nav-link    tnt-section-terms-of-use"  href="/site/terms.html"  tabindex="0" >
                    <span class="nav-label ">Terms of Use</span>
                </a></li><li>
                <a class="nav-link    tnt-section-privacy-privacy"  href="/site/privacy.html"  tabindex="0" >
                    <span class="nav-label ">Privacy Privacy</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-2288497" class="tncms-block"><section id="block-2288497" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2288497 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>PasadenaWeekly.com</strong><br>
    PO Box 1349 <br>
    South Pasadena, CA 91031
    <br>
    
        <strong>Phone:</strong> (626) 360-2811<br>
        <strong>Email:</strong> <a href="mailto:zac@timespublications.com">zac@timespublications.com</a><br>
    
</address></section></div><div id="tncms-block-2288521" class="tncms-block padding-bottom"><div class="follow-links-2288521 follow-links default">
    
    <section id="block-2288521" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-2288521 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/PasadenaWeekly" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/pasadenaweekly" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
            <li>
                <a href="https://instagram.com/pasadenaweekly" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.pasadenaweekly.com",
  "sameAs" : ["https://www.facebook.com/PasadenaWeekly","https://twitter.com/pasadenaweekly","https://instagram.com/pasadenaweekly"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-2288407" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-2288407"><div class="col-xs-12"><small>© Copyright 2022 Pasadena Weekly, PO Box 1349, South Pasadena, CA 91031</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("807cd14c-663f-11ed-ac2e-a3751ae591ec")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': ["union station turkeys", "union station", "union station thanksgiving"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/pasadenaweekly.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-2288515'),
            query_input = d.getElementById('site-search-2288515-term'),
            search_dropdown = d.getElementById('site-search-2288515-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-2288515 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-2288512'),
            query_input = d.getElementById('site-search-2288512-term'),
            search_dropdown = d.getElementById('site-search-2288512-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-2288512 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_2288530').click(function(e){
                                        $('#weather-2288530 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ 
                    /* Copy url to clipboard */
                    function copyLink(url, copyTarget) {
                        /* Populate clipboard */
                        navigator.clipboard.writeText(url);
                        
                        /* Bootstrap popover */
                         $(copyTarget).popover().popover("show").prop("disabled", true);
                        
                        /* Hide popover after timeout */
                        setTimeout(
                            function() {
                               $(copyTarget).popover("hide").popover("destroy").prop("disabled", false);
                            }, 2000);
                    } /*]]>*/</script></body>
</html>